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Abstract. The paper presents a specification and performance characteristics of  

a computer software application developed for rocket design engineering.  

The methodology for the determination of aerodynamic characteristics by the software 

application is based on the Chernabrovkin-Lebyadyev’s experimental and theoretical 

method. The computer simulation results presented in the paper were generated for two 

types of 122-mm calibre rockets, M-21OF Grad and M-21FHE Feniks. The simulation 

results were verified with the results produced using other calculation methods. 
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1. INTRODUCTION 

 

This paper focuses on the external ballistics and aerodynamics of rolling-

symmetrical rockets. The definition of the laws of motion of rockets in near-

Earth space and the determination of mass-inertial and aerodynamic 

characteristics of rockets are the essential problems to be solved in the design 

process of every rocket. Ballistic tunnel tests and live-fire experimental tests are 

time-consuming and require considerable financial resources. It is normal to do 

both types of testing in the final stages of a rocket design engineering cycle.  

The preliminary stages of rocket design engineering involve analytical methods 

based on commercial or proprietary computer software applications intended for 

preliminary design and determination of flight parameters of unguided rockets 

in simulated atmospheric conditions. 

The paper presents a specification and performance characteristics of  

a computer software application developed in C++ and QtCreator graphic 

libraries for rocket design engineering. The methodology for the determination 

of aerodynamic characteristics by the software application is based on  

the Chernabrovkin-Lebyadyev's experimental and theoretical method [1, 2]. The 

computer simulation results presented in the paper were generated for two types 

of 122-mm calibre rockets, M-21OF Grad and M-21FHE Feniks.  

The simulation results were verified with the results produced using other 

calculation methods. 

 

2. DESIGN AND PRINCIPAL ASSUMPTIONS OF  

     THE COMPUTER SOFTWARE APPLICATION 

 
The computing module of the computer software application was 

developed in C++ with Dev-C++ software suite. The graphical user interface 

was developed with QtCreator. According to its principal assumptions, the 

computer software application was to be capable of determining the 

aerodynamic characteristics of rockets and solving systems of differential 

equations which defined the flight of a single-stage unguided rocket. The 

computer software application was provided with a proprietarily developed GUI 

to aid in the design of rockets and the presentation of calculation results.  

The operating principle and the general design of the computer software 

application are shown in Figure 1. The application includes three basic file 

sections: Engine, Interface, and Plotting. The Engine file section contained  

a set of source and header files written to enable the calculation of geometric 

and aerodynamic characteristics of rockets, the determination of flight 

parameters, and the modelling of the Earth’s atmosphere. The Plotting file 

section drives the graphical presentation (plots) of simulation results.  
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The Interface file section handles the HMI interaction with the application 

user, acquisition of input data, display of diagrams and graphical content, and 

data writing and reading. The computer software application also uses Pictures 

and Save file sections which store the required graphic files and written data. 
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Fig. 1. Operating block diagram of the computer software application developed  

for rocket design and flight simulation [3] 

 

3. GUI (GRAPHICAL USER INTERFACE) 

 
The GUI of the computer software application was designed to facilitate  

the use of the application. The implemented text input fields, tables, sliders  

and a variety of buttons markedly reduce the time required to design a rocket  

in the application. The interactive graphic features, images, and hints  

made the use of the software application intuitive to individuals unfamiliar  

with the concepts of rocket engineering.  
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The graphical representation of the shape of a rocket in the design process 

helped verify the geometrical data inputs, including the COG (centre of 

gravity). The scalable plots of the relationships calculated in the software 

application provided a straightforward overview of the calculation results, 

facilitating analysis of specific ranges of the data. The GUI was divided into 

four main tabs with a menu bar and a data update bar (Fig. 2). The sequence of 

the main tabs (Design, Simulation, Ballistic Tunnel, and Tutorial) could be 

rearranged according to user preferences. 

 

 
 

Fig. 2. GUI with its main components highlighted [3] 

(1 – Design tab; 2 – Simulation tab; 3 – Ballistic Tunnel tab; 4 – Tutorial tab;  

5, 6, 7 – Menu bar tabs; 8 – Update Data button; 9 – Data update progress bar) 

 
Opening the Design tab displayed the rocket design interface with six sub-

tabs (Fig. 3). The sub-tabs (Warhead, Fuselage, Motor, Stabilizer Fins, Bottom 

Section, and Ballast) enabled editing the geometric, mass-inertial, and auxiliary 

characteristics and parameters of respective main components of the rocket  

in design. The common features of all sub-tabs included the following:  

1 – Graphical representation of the rocket form; 2 – Text input field pane;  

3 – Edited component engineering drawings; 4 – Auxiliary information pane;  

5 – Overview plan with the highlighted rocket components open in the editing 

mode (Fig. 4). Each sub-tab featured panes specific to the rocket component  

in the design editing mode (Fig. 5). 
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Fig. 3. Sub-tabs [3] 

(1 – Warhead; 2 – Fuselage; 3 – Motor; 4 – Stabilizer Fins; 5 – Bottom Section;  

6 – Ballast) 

 

  

 

 
 

Fig. 4. Common features of all sub-tabs [3] 
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Fig. 5. The Motor sub-tab with its specific panes highlighted [3] 

(1 – Tabulated thrust value input; 2 – Thrust value file input) 

 

The Simulation tab (Fig. 6) and the Ballistic Tunnel tab (Fig. 7) provided 

access to the display of calculation results in the form of plotted graphs. Both 

tabs feature input panes for the initial data, the configuration of plotting 

parameters, and auxiliary information. 

 

 

 
Fig. 6. The Simulation tab with its specific panes highlighted [3] 

(1 – Plot; 2 – Input pane for initial simulation parameters and plotting configuration;  

3 – Auxiliary information drop-down pane) 
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4. INPUT DATA FOR ROCKET DESIGN AND FLIGHT  

  SIMULATION 

 
The Design tab is the main GUI feature which handled the input of data. 

This GUI feature included text input fields and tables for the input  

of geometrical and mass-inertial data of the rocket in design. The subroutine 

source file Pocisk.cpp featured six data classes, Głowica, Kadłub, Brzechwy, 

Silnik, Denna, and Balast (Warhead, Fuselage, Stabilizer Fins, Motor, Bottom 

Section, and Ballast, respectively), which represented the respective 

components of the rocket in design. The data classes contained a series  

of objects in which the following data was stored: dimensions, material 

densities, and additional characteristics corresponding to the specific 

components of the rocket in design. Each data class included the method masa 

(mass), which calculated the mass (weight) of the rocket component being 

edited. The source file also included definitions of separate functions (masa – 

mass, momentbezwladnosci – moment of inertia, srodekmasy – centre of mass, 

and dlugosc – overall length [1]) for the calculation of the mass-inertial 

parameters of the complete rocket. 

At the data input stage, the user could define the warhead outline type 

(tapered, parabolic, ellipsoid, or truncate), the stabilizer fin type (rhomboidal  

or lenticular), and the motor thrust definition data source (tabulated or from  

a file). The thrust data read from a file was automatically displayed in  

the Thrust File pane (Fig. 5) for the user to verify the data validity. 

The computer software application also allowed reading and writing the 

input data from TXT files. If the data were loaded from a file, the software 

application would verify if the loaded file was originally created by it while 

writing design data; this feature offered protection against reading incompatible 

data. Another convenient feature provided in the software application was batch 

resetting of all text input fields to zero (0). It required opening the Edit tab and 

clicking the Reset Parameters button in the tab. This feature helped delete the 

input parameter values quickly to proceed with a new rocket design project.  

If the user wanted to load the input data for editing, they would always have to 

click the Update Parameters button. The data update progress bar was  

a graphical representation of the part of the data update operation that was 

already completed. The software application provided a visual inspection of the 

data inputs in the form of a graphical representation of the designed rocket 

cross-section and the rocket COG (centre of gravity). 
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5. AERODYNAMIC CHARACTERISTICS CALCULATOR AND 

 SOLVING THE SYSTEM OF DIFFERENTIAL EQUATIONS 
 

A source file, Wspolczynniki.cpp, was implemented to enable  

the determination of the aerodynamic characteristics of the rocket in design.  

It was a subroutine which used specific analytical methods (developed by L.S. 

Chernabrovkin and A.A. Lebyadyev [1-4]) to determine the aerodynamic 

coefficients, the pressure centre coordinate, and other parameters. The 

subroutine was the aerodynamic characteristics calculator of the software 

application. The input parameters of its functions included: geometric 

dimensions of the rocket, the velocity of flow around the rocket,  

and a set of tables which contained digitized functions essential for the 

calculator and established from ballistic tunnel tests [4, 5]. 

By calling out subsequent functions, the software application determined  

the following aerodynamic characteristics: zero-lift head resistance coefficient 

for the active and passive sections; second derivative of the head resistance-to-

attack angle ratio; derivative of the lift force-to-attack angle ratio; rocket 

pressure centre coordinate; derivative of the pitching moment-to-attack angle 

ratio; and attenuation factor derivative of the pitching moment-to-roll velocity 

ratio. 
 

 
 

Fig. 7. GUI, the “Ballistic Tunnel” tab [3] 

 

The GUI tab titled Tunel Aero (Ballistic Tunnel) (Fig. 7) could present  

the aerodynamic characteristics discussed above in the form of a graph with  

the calculated coefficient values plotted in the function of the Mach number.  
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The model of the Earth’s atmosphere applied in the calculation of the 

simulated rocket trajectory was based on the standard AS-64 GOST 4401-64a. 

Its numerical implementation was stored in the subroutine source file 

Atmosfera.cpp [6, 7]. The input data of the relevant subroutine functions 

included: ambient temperature and barometric pressure at the rocket launch site 

and the reference elevation for the calculation of output parameters.  

The subroutine processed the input data and returned the magnitudes defining 

the atmosphere at a predefined elevation (i.e. the air density and barometric 

pressure, the velocity of acoustic wave propagation, and the acceleration  

of gravity). Another capability of the software application included solving  

of the system of differential equations which defined the motion of an unguided 

rocket within the plane of firing [8-10]. 

The numerical solution of the system of differential equations was 

processed by the subroutine stored in the source file Trajektoria.cpp. The 

subroutine source file featured three functions, Balistyczna (ballistic), RK4 and 

Trajektoria (trajectory) [2]. The body of the first function, Balistyczna, had the 

foregoing system of equations implemented and the callouts of the functions 

stored in the source files Wspolczynniki.cpp and Atmosfera.cpp. The first 

function calculated the transient values of mass, motor thrust, the moment of 

inertia, aerodynamic coefficients, forces, and moments applied to the simulated 

rocket. The function Trajektoria (trajectory) determined the maximum duration 

of the rocket flight to allow the determination of the critical length of the tables 

which read the simulation results. The system of differential equations was 

solved by applying the fourth order Runge-Kutta method (RK4) with a variable 

integration step to reduce the calculation processing time [9, 11, 12]. Aside 

from all structural parameters of the designed rocket, the input data of the 

subroutine included the launch system elevation angle and the ambient 

temperature and barometric pressure at the launch pad. 

The function Trajektoria (trajectory) included a loop whose start of 

execution was tantamount to the simulated launch of the rocket (t = 0 s). Each 

subsequent iteration of the loop execution increased parameter t by the 

respective integration step, called out the function RK4 and overwrote the 

subsequent elements in the tables of results. The subroutine finished the 

simulation process when the flight altitude of the rocket, y, assumed a negative 

value (which was tantamount to the impact on the simulated ground surface). 

Moreover, if any of the variables implemented in the function code assumed the 

value NaN (infinite), a suitable conditional function terminated the loop 

execution and displayed a warning message of invalid input data. The 

simulation results were displayed as graphs in the Simulation tab of the GUI 

(Fig. 8). The user software could select the variables to be displayed on the axes 

x and y of the plotted y=f(x) function. 
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Fig. 8. GUI, the “Simulation” tab [3] 

 

6. OTHER OPTIONS, APPLICATIONS AND DEVELOPMENT 

 OPPORTUNITIES OF THE COMPUTER SOFTWARE 

 APPLICATION 

 

The software application featured the Save Graph command for exporting 

the simulation results (resulting in an export of the displayed graph into 

numerical values saved to a TXT file at a path specified by the application 

user). Another convenient feature were the Information tabs (each in every 

module of the GUI) with text descriptions of selected rocket engineering 

concepts, in addition to the essential explanation of notations and the operating 

principle of the application. A beginner user of the application could use  

the Tutorial to understand the correct way of using the software application.  

Yet another convenient feature was the pane titled Parametry m/b (mass-inertial 

parameters) in the Ballast tab. When the input data was entered  

in the application GUI, the panel displayed detailed mass-inertial parameters  

of the rocket in design (including the values of the mass of individual 

components, the centre of mass of the rocket, and more). Unauthorized access 

to the application was prevented by a user login input window displayed before 

accessing the main application window at every start of the application.  

The user was required to enter a valid user login and password, the latter  

of which could be modified in the Change Password tab of the GUI. 
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7. SIMULATION RESULTS FOR A SELECTED TEST OBJECT  

 

The computer software application was tested with two types of 122 mm 

calibre rockets, M-210F Grad and M-21FHE Feniks. The flight parameter 

results generated for the rockets in the application were compared to the actual 

firing solution tables of the ordinance [13]. Examples of the simulation results 

with the firing range and velocity variations in time with reference to specific 

elevation angles of the launch system are shown in Fig. 9 and 10. 

 

 

Fig. 9. Flight trajectories of the M-21OF rocket with specific launch system  

elevation angles [3] 

 

 

Fig. 10. Velocity of the M-21OF rocket with specific launch system elevation  

angles [3] 



K. Motyl, F. Musiałek 78 

8. CONCLUSIONS 
 

The developed computer software application enables the design  

and simulation of structurally simple solid-propellant rockets. Therefore,  

the application can be used during the preliminary design of munitions  

for rocket artillery systems. The application can be useful in the rocket 

munitions model industry and laboratory exercises in rocket engineering 

learning studies. 

The computer software application included a clear GUI, interactive 

modelling of rockets, information panes, and many more features for enhanced 

user convenience, enabling its application in scientific research and learning. 

The implementation of the software application code in C++ allowed 

deployment on various hardware platforms without any need for professional 

calculation suites. The presentation of results on graphs which could  

be exported to third-party applications favoured convenience of analysis  

of the designed and simulated characteristics. 

Given that the software application uses an object-driven programming 

paradigm, it is possible to easily expand the application with more modules. 

Further development of the software application may enable design, simulation, 

and animation of guided missiles, both winged and multi-stage. 

The aerodynamic characteristics determined in the software application for  

the M-210F Grad and M-21FHE Feniks rockets were largely approximate to 

their reference characteristics determined with other options.  

The verification of the results obtained for the essential flight parameters  

of the rockets revealed high conformity with the reference firing solution tables, 

with an average error of 10%. 

The developed computer software application should include algorithms 

for the determination of aerodynamic characteristics of any aerodynamic system 

and a module for 3D visualisation of rocket / missile flight, driven by graphical 

libraries. The application could be then used as a learning aid in rocket 

engineering, external ballistics, and rocket and missile aerodynamic 

engineering. 
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Aplikacja komputerowa do projektowania  

i symulacji niekierowanych pocisków rakietowych 
 

Krzysztof MOTYL, Filip MUSIAŁEK 

 
Wojskowa Akademia Techniczna, Wydział Mechatroniki i Lotnictwa,  

ul. gen. Sylwestra Kaliskiego2,  

00-908 Warszawa 
 

Streszczenie. W pracy zamieszczono opis i charakterystykę użytkową opracowanej 

aplikacji komputerowej do projektowania pocisków rakietowych. Metodyka 

wyznaczania charakterystyk aerodynamicznych przez opracowane oprogramowanie 

bazuje na metodzie teoretyczno-doświadczalnej Czernabrowkina i Lebiadiewa. 

Zamieszczone w pracy wyniki symulacji komputerowej przeprowadzono dla 122 mm 

pocisku rakietowego M-21OF Grad oraz M-21FHE Feniks i zostały poddane 

weryfikacji z wynikami uzyskanymi innymi metodami obliczeniowymi. 

Słowa kluczowe: symulacja komputerowa, współczynniki aerodynamiczne, pocisk 

rakietowy 

 

 

 

 

  

 

 

 


