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Studium przypadku: struktura wiedzy 
w badaniach rynku stali
Lee Hyunjoung, Sohn Il 

W życiu codziennym zajmujemy się danymi na większą 
i na mniejszą skalę. Z perspektywy państw ważne są 

wartości produktu krajowego i wzrost ekonomiczny, a dla firm 
najistotniejsze są wyniki sprzedaży. Pracownicy naukowi anali-
zują dane i wyniki badań, a studenci używają swoich ocen jako 
danych, które pozwalają im wstępować na uniwersytety. Z tego 
punktu widzenia nie ma nikogo, kto by nie miał do czynienia 
z żadnymi danymi. 

Jednak wzrokowe znalezienie informacji w danych nie jest 
łatwe. Szczególnie dotyczy to obecnej ery Big Data, w któ-
rej różnego rodzaju dane gromadzi się bardzo szybko i na 
ogromną skalę. Dane w jakiś sposób pokazują rzeczywistość, 
ale nie wystarczy się im przyjrzeć, aby je zrozumieć. Aby uzy-
skać zawarte w nich informacje, trzeba te dane przeanalizować. 

Naszym zamiarem było udostępnienie pracownikom nauko-
wym przydatnych informacji, uzyskanych poprzez analizę rze-
czywistych danych. Podjęliśmy próbę analizy „struktury wiedzy” 
w badaniach rynku stali, a wyniki tej pracy naukowej zostały 
opublikowane na łamach „Steel Research International”. W ten 
sposób chcieliśmy usystematyzować dotychczasowe badania 
branży stalowej i stworzyć przewodnik przydatny w rozwijaniu 
tych badań. Rozwój badań w przemyśle stalowym następuje 
szybko, zarówno w aspekcie akademickim, jak i praktycznym. 
Zadaliśmy sobie pytanie: jakie cechy wyróżniają ten proces 
rozwoju? Osoby biegłe w interpretacji danych lub prowadzące 
badania w określonej dziedzinie potrafią je wychwycić już po 
zapoznaniu się z jakimiś dokumentami badawczymi albo licz-
bami. Jednak dla przeciętnego człowieka są to tylko listy liczb 
i podobnych elementów. Dlatego właśnie potrzebna nam była 
metoda wyszukiwania pewnych cech lub struktur z samych 
danych, czyli z samej rzeczywistości. I to właśnie nazywamy 

„analizą sieci Big Data”. Poniżej szczegółowo omawiamy sposób 
zbierania i analizowania danych, które zostały opublikowane 
w „Steel Research International” [1] – numer ze stycznia 2015 r. 
Dzięki temu można zrozumieć strukturę wiedzy w przemyśle 
stalowym. 

Etap 1: Zbieranie danych. Zbieranie informacji bibliograficz-
nych z artykułów opublikowanych w periodyku „Steel Rese-
arch International”. Są to artykuły akademickie, recenzje, 
analizy przypadków, korekty, recenzje książek, wytyczne 
redakcyjne itd. Z tego zbioru pozostawiliśmy tylko arty-
kuły akademickie, recenzje i analizy przypadków, ponieważ 
inne nie mają bezpośredniego wpływu na strukturę wiedzy 
w badaniach rynku stali. 

Etap 2: Wyodrębnianie danych. Wyodrębnianie słów kluczo-
wych z zebranych artykułów. Te słowa kluczowe wskazują 

tematykę artykułów, więc można je uzyskać z list słów klu-
czowych, abstraktów i tytułów artykułów. 

Etap 3: Oczyszczanie danych. Różni autorzy mogą różnie zapi-
sywać słowa kluczowe, więc trzeba wykonać ich standaryza-
cję. W oczyszczaniu zbioru słów kluczowych pomogli nam 
również eksperci z branży stalowej. 

Etap 4: Porządkowanie danych. Aby sieć można było analizować 
pod kątem struktury wiedzy, dane muszą zostać odpowied-
nio uporządkowane. W tym przypadku utworzyliśmy sieć 
dwumodalną z artykułami i słowami kluczowymi, a póź-
niej, do celów analizy rocznikowej, dodaliśmy lata publikacji 
(patrz rys. 1). 

Etap 5: Przekształcanie danych w sieć jednomodalną. Trudno 
wykryć strukturę słów kluczowych na podstawie kierunko-
wych relacji w sieci dwumodalnej, czyli relacji między arty-
kułami i słowami kluczowymi (patrz rys. 2). 

Etap 6: Przeprowadzenie analizy danych sieciowych. Etap ten 
obejmuje analizę centralności i spójnych podgrup. 
Etap 6.1: Wysoki wskaźnik centralności uzyskany w anali-

zie centralności pewnych słów kluczowych oznacza, że 
wiele słów kluczowych występuje jednocześnie w tych 
samych artykułach. Wysoki wskaźnik centralności bli-
skości oznacza krótką odległość geodezyjną od innych 
słów kluczowych w sieci, ujawnia więc pozycję, która 
najszybciej może wpływać na całość badań rynku stali. 
Słowo kluczowe z wysokim wskaźnikiem centralno-
ści pośredniczenia łączy obszary badawcze w branży 
stalowej. Te słowa kluczowe prowadzą do zbieżności  
badań. 

Etap 6.2: Przeprowadzamy analizę spójnych podgrup, aby 
zrozumieć podobszary w badaniach stali. Zbiór słów 

Rys. 1. Sieć dwumodalna (artykuł – słowo kluczowe)

Rys. 2. Sieć jednomodalna (słowo kluczowe – słowo kluczowe)
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kluczowych występujących jednocześnie w wielu arty-
kułach można uznać za jeden z obszarów badań. 

Etap 7: Przeprowadzamy dodatkowe analizy danych. Wykonu-
jemy dodatkowe analizy badawcze zgodnie z celem bada-
nia. W tym przypadku utworzyliśmy mapy na podstawie 
wyników badań, aby na bazie spójnych podgrup zrozumieć 
kierunek rozwoju badań stali. 

Następnie została przeprowadzona analiza, której celem było 
zrozumienie struktury wiedzy w badaniach rynku stali. Teraz 
zajmiemy się czwartym etapem, czyli porządkowaniem danych. 
Analiza sieci została przeprowadzona w programie NetMiner. 

Etap 4: Organizacja zebranych danych zaczyna się od utworze-
nia sieci dwumodalnej, takiej jak na rysunku 3 a. Importu-
jemy zebrane dane do programu NetMiner (File > Import > 
Text File lub Excel File). 

Jeśli dane są importowane z Excela, nie trzeba konfiguro-
wać dodatkowego separatora, ale w przypadku danych z pliku 
tekstowego dzielimy kolumny danych za pomocą opcji Sepa-
rator. Ponadto w opcjach importowania zaznaczamy Linked 
List w ramce 2-mode Network, ponieważ zebrane dane mają 
postać prostej listy relacji w sieci dwumodalnej. Po zaimporto-
waniu danych w bieżącym pliku NetMinera zostanie utworzony 
główny zbiór węzłów, podrzędny zbiór węzłów i sieci dwumo-
dalne. W drzewie pliku roboczego widać, że utworzona nazwa 
pliku roboczego zgadza się z nazwą importowanego pliku (patrz 
rys. 3 b). 

Etap 5: Dane importowane do NetMinera to sieć dwumo-
dalna złożona z par artykuł – słowo kluczowe. Aby można 
było analizować strukturę wiedzy w badanej dziedzinie, 
trzeba przekształcić tę sieć w sieć jednomodalną zbudo-
waną z par słowo kluczowe – słowo kluczowe. Sieć dwumo-
dalną możemy przekształcić w sieć jednomodalną, wydając 
polecenie Transform > Mode > 2-mode Network. Następnie 
w ramce Output Network w okienku Main process zazna-
czamy Overlap (Sub*Sub), a w ramce Proximity Measures 
wybieramy kolejno Type > Correlation > Inner Product 

(patrz rys. 4 a). Gdy to zrobimy, klikamy Run Process i poja-
wia się kontekstowe menu z pytaniem, czy utworzyć plik 
roboczy. Jeśli klikniemy Yes, wówczas istniejące dane będą 
zachowane i zostanie wygenerowany podrzędny plik robo-
czy, taki jak na rysunku 4 b. W programie NetMiner liczby 
znajdujące się po nazwach zbioru węzłów i sieci oznaczają 
odpowiednio liczbę węzłów i atrybutów węzłów oraz liczbę 
łączy i atrybutów łączy. Na przykład Steel Research [5661*0] 
w nowo wygenerowanej sieci jednomodalnej oznacza, że cał-
kowita liczba węzłów to 5661 i nie ma żadnych atrybutów 
węzłów. Natomiast Overlap (Steel Research) [26385*0] w sieci 
jednomodalnej oznacza, że całkowita liczba łączy to 26 385 
i nie ma atrybutów łączy. 

Wygenerowana macierz współwystępowania słów kluczo-
wych wygląda tak jak w tabeli 1. Można ją zobaczyć w jed-
nomodalnej sieci Overlap (Steel Research). Każda komórka tej 
macierzy zawiera informację o częstotliwości współwystępo-
wania słowa kluczowego i oraz słowa kluczowego j w okresie 
objętym badaniem (lata 1990–2013), natomiast na przekątnej 
widzimy częstość słowa kluczowego i w tym samym okresie. 
W szczególności w macierzy współwystępowania widzimy, że 
słowo microstructure (mikrostruktura) pojawiło się w ciągu 
24 lat jako słowo kluczowe w 95 pracach naukowych, a w 4 
z nich wspólnie z duplex stainless steel (stal nierdzewna typu  
duplex). 

Rys. 3. Ekran wyświetlany w trakcie importowania danych: (a) importo-

wanie danych sieciowych; (b) plik roboczy po zaimportowaniu danych 

do programu NetMiner

Rys. 4. Przekształcanie sieci jednomodalnej w dwumodalną:  

(a) przekształcanie sieci; (b) wygenerowany plik roboczy

Tabela 1. Macierz występowania par słów kluczowych
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Z macierzy współwystępowania możemy więc odczytać czę-
stość występowania słów kluczowych w badanym okresie. Co 
więcej, dzieląc tę macierz na lata, można ustalić, jakie badania 
dominowały w każdym roku (patrz tab. 2). 

Dodatkowo możemy również zbadać częstość występowania 
par słów kluczowych, tak jak w tabeli 3. Dzięki temu mamy 
możliwość znajdowania słów kluczowych towarzyszących 
wybranym słowom kluczowym, na bazie których prowadzone 
są badania. Po wykonaniu wizualizacji wyników możemy nawi-
gować po słowach kluczowych, a także eksplorować inne słowa 
kluczowe. 

Etap 6: Na podstawie wyniku przekształcenia w sieć jednomo-
dalną można zobaczyć, które słowa kluczowe i podobszary 
badań są uważane za istotne w badaniach przemysłu sta-
lowego. W tym celu przeprowadzamy analizę centralności 
i spójnych podgrup. 
Etap 6.1: Aby wykonać analizę centralności, wybieramy 

pożądaną metodę analizy z menu Analyze > Centra-
lity. W tym badaniu została przeprowadzona analiza 

centralności stopnia (Degree), pośredniczenia dla węzłów 
(Betweenness > Node) i bliskości (Closeness). Chcąc obli-
czyć centralność stopnia, w okienku Main process wybie-
ramy metodę wyznaczenia tego wskaźnika. Podstawą 
obliczania może być liczba wszystkich łączy do innych 
węzłów albo suma wag łączy. Na ogół przyjmujemy, że 
istnienie łącza jest ważniejsze niż jego waga i w oparciu 
o to założenie mierzymy centralność stopnia, ale czasami 
przydatna jest również druga opcja. W analizie central-
ności bliskości istotna jest osiągalność całej sieci, więc 
w okienku Pre-process jest domyślnie zaznaczona opcja 
Dichotomize. W okienku Main process trzeba również 
ustawić opcję w ramce Unreachable Handling (jak trakto-
wać węzły nieosiągalne). Najczęściej zaznaczamy Ignore 
Unreachable (ignoruj nieosiągalne). W analizie central-
ności pośredniczenia interesują nas również węzły i ich 
położenie, więc nie musimy uwzględniać wagi. Aby nie 
uwzględniać wag łączy, w okienku Pre-process domyślnie 
jest zaznaczone pole wyboru Dichotomize (patrz rys. 5). 

Wynik analizy centralności w programie NetMiner 
przedstawiono na zakładkach [R] Main, [T] Centrality 
Vector, [M] Spring i [M] Concentric. [R] oznacza tu raport, 
[T] – tabelę, a [M] – mapę. Tak więcej rezultatem analizy 
centralności jest jeden raport, jedna tabela i dwie mapy. 
Zakładka [R] Main zawiera informacje o procesie i pod-
sumowanie wyników. Rozkład wskaźnika centralności 
i wskaźnik centralizacji sieci są pokazane w punkcie Out-
put Summary. Z kolei wskaźniki centralności każdego 
z węzłów można zobaczyć na zakładce [T] Centrality 
Vector. Mapa z wizualizacją, wygenerowana za pomocą 

Tabela 2. Częstość występowania słów kluczowych w latach 1990–2013

Tabela 3. Częstość występowania par słów kluczowych
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algorytmu sprężynowego, znajduje się na zakładce 
[M] Spring. Na zakładce Display (w dolnej części 
obszaru sterowania procesem) można zmienić 
styl mapy. Na mapie [M] Concentric węzły z wyż-
szym wskaźnikiem centralności znajdują się bliżej 
środka, więc z łatwością można wyszukać węzeł 
z najwyższym wskaźnikiem. W tym przykładzie 
pokazano analizę centralności stopnia. W macierzy 
współwystępowania nie uwzględnia się kierunku, 
więc wskaźniki centralności stopnia, wchodzący 
i wychodzący, mają jednakowe wartości. 

Uporządkowane wyniki analizy centralności 
w badaniach branży stalowej pokazano w tabeli 
4. Słowa kluczowe microstructure i finite element 
method (metoda elementów skończonych) mają 
wysokie wskaźniki centralności stopnia i pośred-
niczenia, więc oba są uwzględniane w badaniach 
i łączą podobszary badań, co sprzyja badaniom 
zbieżności słów kluczowych. Poza tym słowa 
kluczowe microstructure, mechanical properties 
(właściwości mechaniczne) i continuous casting 
(odlewanie ciągłe) znajdują się na miejscach, które 
sprzyjają rozpowszechnianiu się tych słów w dal-
szych badaniach. Dlatego też pracownicy naukowi, 
którzy dopiero zaczynają zajmować się badaniami 
rynku stali, powinni wziąć pod uwagę te słowa 
kluczowe. 

Etap 6.2: Przed analizą spójnych podgrup oka-
zało się, że 94,2% wszystkich słów kluczowych 
w latach 1993–2013 pojawia się mniej niż pięć 
razy, uznając więc, że mają one stosunkowo 
niewielki wpływ na badania, postanowiliśmy 
je wykluczyć z analizy. W tym celu trzeba 
najpierw do głównego zbioru węzłów (Steel 
Research [5661*0]) dodać częstotliwość jako 
atrybut węzła. Następnie, na pasku narzędzi 
NetMinera, klikamy przycisk Query Composer, 

Rys. 5. Obszar sterowania procesem w trakcie analizy centralności: (a) centralność 

stopnia; (b) centralność bliskości; (c) centralność pośredniczenia

Tabela 4. Analiza centralności słów kluczowych

Rys. 6. Wyniki centralności stopnia: (a) [R] Main Report; (b) [T] Degree Centrality Vector; 

(c) [M] Spring; (d) [M] Concentric
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aby w obszarze edycji danych pojawiło się to, co widać na 
rysunku 6. W tym przykładzie, po wybraniu zbioru węzłów 
lub sieci w okienku QuerySet Status, wpisujemy zapytanie 
(ramka Query) i klikamy kolejno Try > Apply > Run, aby 
wyodrębnić słowa kluczowe, które występują więcej niż pięć 
razy. Tym sposobem spośród 5661 słów kluczowych do ana-
lizy spójnych podgrup wyodrębniliśmy 321, które pojawiają 
się częściej niż pięciokrotnie (rysunek 7). 

Następnym krokiem było przeprowadzenie analizy wspólnoty. 
W ten sposób powstało więcej wewnętrznych (w grupach) niż 
zewnętrznych (między grupami) połączeń słów kluczowych, co 
pozwoliło skupić się na analizie podobszarów badań. Aby wyko-
nać analizę wspólnoty, wybieramy kolejno Analyze > Cohesion 
> Community > Modularity. W tym przykładzie, w okienku 
Main Process na obszarze sterowania procesem, należy w ramce 
Algorithms wybrać algorytm. Najpopularniejszym algoryt-
mem jest CNM1, który gwarantuje przyzwoite rezultaty, cho-
ciaż ze wszystkich dostępnych opcji działa najwolniej. Gdy 
chcemy podzielić sieć na określoną liczbę wspólnot, niezależ-
nie od wskaźnika modułowości, korzystamy z opcji Include 

Nonoptimal Output. Wyniki analizy wspólnoty pojawiają się na 
zakładkach [R] Main, [T] Community Partition i [M] Clustered. 
Raport zawiera wskaźnik najlepszej modułowości, natomiast 
z tabeli na zakładce [T] Community Partition możemy odczytać 
informacje o przynależności węzłów do podgrup. Na zakładce 
[M] Clustered znajduje się mapa klastrowania spójnych pod-
grup, wygenerowana na podstawie wskaźnika modułowości. 
W tym przykładzie mapy klastrów każdej spójnej podgrupy 
mogą mieć różne kształty i kolory, które ustawiamy w obszarze 
sterowania procesem, na zakładce Display (okienko Node Style, 
ramka Node Attribute Styling) (patrz rys. 8). 

W wyniku analizy spójnych podgrup w badaniach stali wyod-
rębniono w sumie osiem podgrup (patrz tab. 5). Liczbę słów 
kluczowych, liczbę łączy i połączenia wewnętrzne (gęstość) 
można znaleźć za pomocą polecenia Analyze > Properties > 
Group. Informacje o połączeniach zewnętrznych uzyskujemy 
w wyniku dodatkowej analizy badawczej. 

Rys. 7. Kompozytor zapytań

Rys. 8. Wyniki analizy spójnej podgrupy: (a) [T] Community Partition; 

(b) [M] Clustered

Tabela 5. Podobszary badań stali
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Etap 7: Aby lepiej zrozumieć podobszary badań przemysłu 
stalowego, kategorie badawcze podzielono na połączenia 
wewnętrzne i zewnętrzne (patrz rys. 9). Podgrupy w pod-
obszarach mających wysoki wskaźnik zarówno połączeń 
wewnętrznych, jak i zewnętrznych, to obszar badawczy 
głównego nurtu (ang. main stream research area), który 
zasługuje na uwagę jako rozwijająca się dziedzina badań. 
Podgrupy, które mają wysoki wskaźnik połączeń wewnętrz-
nych, ale niski wskaźnik połączeń zewnętrznych, to obszar 
badawczy niezależnego rozwoju (ang. growth research area), 
a podgrupy, w których oba wskaźniki są niskie, to obszary 
badawcze następnej generacji (ang. next generation research 
area), które nie mają jeszcze struktury i są badane osobno. 

Rys. 9. Mapowanie obszarów podgrup w badaniach stali

Fragment pochodzi z książki:  

Big Data w przemyśle  

Lee Hyunjoung, Sohn Il 

Wydawnictwo Naukowe PWN, 2019

I wreszcie podgrupy, które mają niski wskaźnik połączeń 
wewnętrznych, ale wysoki wskaźnik połączeń zewnętrznych, 
to obszar badawczy trendów (ang. trend research area), który 
cechuje się dużą skalowalnością. 

Celem wykonania tej pracy było poznanie struktury wiedzy 
w badaniach nad przemysłem stalowym, przy użyciu analizy 
sieciowej Big Data. W tym celu wykorzystano publikacje ukazu-
jące się na łamach „Steel Research International”. Wyniki analizy 
pozwalają nam lepiej zrozumieć zebrane dotychczas opracowa-
nia badań. Co więcej, czytelne wydzielenie obszarów na podsta-
wie podgrup może być cenną wskazówką dotyczącą kierunku 
kolejnych badań. Konieczne jest jednak przeprowadzenie bar-
dziej wyczerpujących badań na ten temat, z uwzględnieniem 
zawartości innych branżowych periodyków, co wykracza poza 
ramy tej pracy. 

Przypisy
1	 Jest to akronim utworzony od nazwisk twórców tego algorytmu: 

Clauset, Newman i Moore (przyp. tłum.).
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